Open Up the Bushnell 1500

2»

Comments

  • Tank.Bobcat.WattsTank.Bobcat.Watts DriverWedge is my middle name Banned Posts: 49
    If this works on mine I owe you guys big
    USGA Handicap: +2 Fitting center: Pure Impact Golf Studio Low round in competition: 65 Low round with pals: 62 Golf Junkie, tinkerer, short game coach Born to golf
  • NuGNuG Members Posts: 180
    edited Aug 20, 2013 #33
    Szeto wrote:


    I need help to fix a broken Bushnell Tour V2 rangefinder, which just stopped working one day.



    If I remove the battery, put it back in, and look thru the lens without pushing anything, it is just blank like normal. Once I press the power button, the entire display (i.e. all the black lines) lights up and it doesn't go away. I then have to remove the battery to prevent it from being drained, and the whole cycle starts again.



    I sent the rangefinder to Bushnell, and they said the circuit board is broken and they refused to fix it. And they charged me $25 for the privilege of getting the unit inspected!



    Is there anything I can do to get it fixed? I don't use it frequently and it still looks new. Thanks for any ideas you may have.




    I have the same exact issue with mine. I'm going to open mine up and see if I can see anything that is fried on the circuit board. It does sound unusual to have a broken circuit board on an item that is completely sealed up and weather proof.



    When did you buy yours and when did you have battery issues?
  • hhprohhpro Members Posts: 26
    My 1500 just started acting odd......laser operates fine but I'm killing batteries for some reason.....getting one round on a

    fresh battery and then LOB shows up and the 1500 shuts down fast.



    Anyone seen this or have any idea what could cause this issue? thank you for ANY help......
  • kailam19kailam19 Members Posts: 237 ✭✭
    hopefully you guys can help, im seeing the cross circle and everything else but i only only getting a single digit # with the others behind non visible/skewed. Any help would be great.
  • DrJetDrJet Members Posts: 284 ✭✭
    Thanks for the information. My Bushnell 1500 could not pick up distance farther than 120 yards. Now it can pick up an object farther than 360 yards. image/superman.gif' class='bbc_emoticon' alt=':superman:' />
    My bag:

    Titleist 917D3 w/ Tour AD BB S
    Titleist 909 15 or XXIO 4 wood
    Miura 202 3-p NS pro S Pured
    Fourteen RM 12, 52 and 58
    Scotty Cameron 2.6
  • KMeloneyKMeloney Members Posts: 4,725 ✭✭
    NuG wrote:

    Szeto wrote:


    I need help to fix a broken Bushnell Tour V2 rangefinder, which just stopped working one day.



    If I remove the battery, put it back in, and look thru the lens without pushing anything, it is just blank like normal. Once I press the power button, the entire display (i.e. all the black lines) lights up and it doesn't go away. I then have to remove the battery to prevent it from being drained, and the whole cycle starts again.



    I sent the rangefinder to Bushnell, and they said the circuit board is broken and they refused to fix it. And they charged me $25 for the privilege of getting the unit inspected!



    Is there anything I can do to get it fixed? I don't use it frequently and it still looks new. Thanks for any ideas you may have.




    I have the same exact issue with mine. I'm going to open mine up and see if I can see anything that is fried on the circuit board. It does sound unusual to have a broken circuit board on an item that is completely sealed up and weather proof.



    When did you buy yours and when did you have battery issues?




    Digging up an oldish thread here… My issue as of a few days ago is exactly as you guys describe -- a press of the button brings up every possible part of the display, and no functionality but this. Mine goes back off without pulling the battery, but each button press just brings up everything again.



    Can anyone else confirm that this is a circuit board issue (and that there's no adjustment that can be made otherwise)? Thanks, folks.



    PS -- One thing that I found interesting: despite my Pinseeker 1500 being a non-slope version, the slope function is obviously built into this unit, since angle digits and a degree symbol, along with +/- yardage digits, appear on the display as well. I guess it's simply been blocked out by the software in the unit.
  • JSchrammJSchramm Members Posts: 2
    edited Nov 23, 2014 #38
    Posting error
  • JSchrammJSchramm Members Posts: 2
    I wanted to add an observation I've made while working with these 1500's. The waterproof seals can be given a fighting chance again by using a quality grade clear silicone sealant. Make sure it's the silicone and not just some bathroom caulking that may be laying around the house. The silicone sealant will provide plenty of adhesive ability to keep things in place. Excess sealant can easily be cleaned of by hand after it sets and leave the unit looking like it's never been touched. Don't be sloppy with the silicone, it doesn't take much to accomplish this and clean up is much nicer.
  • PDoNPDoN Members Posts: 1,161
    The laser fix worked for me. Unbelievable
    Superfast 1.0 TP
    913 FD 15*
    Rocketbladez Tour 3-P
    Red Saw Vokeys
    Scotty Select Squareback
  • pmveilleuxpmveilleux Members Posts: 29 ✭✭
    I am one of the early posters of this thread and i agree, amazing. I now toggle between my old 1500 & newer 1600. I must admit i like the 1500 better.



    Nice to see the power of the internet has helped so many.
  • ParHunterParHunter Members Posts: 450 ✭✭
    PDoN wrote:


    The laser fix worked for me. Unbelievable


    For me the range increased from about 140 yards to 170 yards but it didn't fix it completely.
  • NoCalHackNoCalHack Posts: 358 ✭✭
    Omg. So glad I found this thread. Going to try it out. Almost threw my 1500 away and was eyeing the jolt model. But who needs the dumb jolt anyways?
  • Anyone who had problems with the graphics in ther TE version? Sometimes all 3 digits dissapear but most times just the last one.. Any clue?
  • middie8middie8 Members Posts: 585 ✭✭
    edited Nov 18, 2015 #45
    I have one of these and if there isnt a prism on the flag i get nothing. if there is a prism i get spotty results at best. I sent it to bushnell and they said the prisms were out of alingment. I guess i should try this.
  • TU_OwlTU_Owl Posts: 339
    I am reviving this thread! It took a lot of small adjustments and testing, which took putting the lens and cover back on and running out side to the streets to get long enough yardages, but it finally dialed in! good as new! the pinseeker and the scanner both work flawlessly. Thanks OP!!
  • knuteknute Members Posts: 3
    Bishop wrote:


    I got 2 TE 1500s. One works but is slowly starting to not pick up distances over 150 yds. Its performance is getting progressively worse. It sounds like the same symptoms as others who did this repair. Im planning on realigning the laser as described soon.



    My question for anyone is regarding my 2nd unit. When I push the button to get a reading the display just "freezes". It shows the pinseeker logo, the cross hairs, and the digits for the distance read "1888 Y M". And on the bottom it shows "+18* > 888". That all shows up when I press the button, and it just locks up, or "freezes" for lack of a better term. It seems like it shows everything the read out is capable of displaying all at once. Then the screen goes blank after the 20 or so seconds without hitting the button, just like its supposed to.



    Also, there seems to be a very slight rattle when shaken. Other than that the unit looks brand new.



    Has anyone had similar issues? Any suggestions? If I dont get any replys, Im thinking of atleast trying the laser adjustment to see if that might fix it. Any help is appreciated.
    i just bought a used 1500 with slope and i get the same 1888 y m and + 18 etc etc...help!
  • knuteknute Members Posts: 3
    Bishop wrote:


    Adjusted the laser as described and got it picking up flags at 280+ yds. And there wasnt any wind so the flags were laying down, which anyone with a laser knows, makes it more difficult. I picked up a large American flag at 429 yds as well. After reading the instructions and looking at the pictures it was fairly simple. So thank you to everyone who posted information. Now all I need is some help with my other 1500. Im fairly sure its problems are not laser alignment issues. Im going to operate on it in the near future and Ill post the results if I can bring it back to life.
    so what happened with the 2nd unit? i have same problem
  • Precision Pro GolfPrecision Pro Golf Sponsors Posts: 251 ✭✭
    Color us impressed by all of those on this thread who are finding various ways to fix their rangefinders. That's very resourceful of you!



    On the flip side... color us UNimpressed by a certain rangefinder company's customer service. Being charged $25 to inspect a broken rangefinder doesn't seem right. (Just FYI... if you write to us at Precision Pro Golf that your rangefinder isn't working, we're either going to fix it (for free) or we're going to replace it with a brand new one.) Unfortunately, we've heard these stories from golfers before.



    If you're unable to MacGyver your rangefinder back together and instead find yourself in the market for a replacement, we have a special offer for everyone of this thread. We're offering you 25% OFF when you trade in your broken rangefinder for one of our NX7 series rangefinders. To claim this offer, you can email [email="[email protected]?subject=Broken%20Bushnell%20Trade-In%20Offer&body=Hi%20Seth%2C%20%0A%0A"][email protected][/email] to receive the discount code.



    We hope you're all able to have a working rangefinder back in your golf bag one way or another!
    Swing with Confidence. Hit More Greens.
    www.precisionprogolf.com

    $20 OFF with Discount Code GOLFWRX. 


    PPG-_Swing_With_Confidence.jpg
  • knuteknute Members Posts: 3
    Bishop wrote:


    I got 2 TE 1500s. One works but is slowly starting to not pick up distances over 150 yds. Its performance is getting progressively worse. It sounds like the same symptoms as others who did this repair. Im planning on realigning the laser as described soon.



    My question for anyone is regarding my 2nd unit. When I push the button to get a reading the display just "freezes". It shows the pinseeker logo, the cross hairs, and the digits for the distance read "1888 Y M". And on the bottom it shows "+18* > 888". That all shows up when I press the button, and it just locks up, or "freezes" for lack of a better term. It seems like it shows everything the read out is capable of displaying all at once. Then the screen goes blank after the 20 or so seconds without hitting the button, just like its supposed to.



    Also, there seems to be a very slight rattle when shaken. Other than that the unit looks brand new.



    Has anyone had similar issues? Any suggestions? If I dont get any replys, Im thinking of atleast trying the laser adjustment to see if that might fix it. Any help is appreciated.
    yeah me! same problem...did you fix the 2nd unit?
2»
Sign In or Register to comment.