New iGolf Neo Model

1151617181921»

Comments

  • DaveLeeNCDaveLeeNC Members Posts: 5,155 ✭✭
    edited Jun 18, 2010 #602
    I had my first round on the course today with my new Neo. While it wasn't perfect, It was a pretty positive experience. For reference I had owned one of the original iGolf Caddie devices and (while I ultimately did not find it totally unusable) I found it barely useable for my purposes (accuracy and 'stability of readings' concerns). I am primarily a laser guy, but would prefer to have 'GPS data' for approach shots from greater than around 175'ish yards (where Front/Middle/Rear is more useful to me than actually yardage to the green).



    While I carried all 3 devices (laser, Caddie, and Neo) I mostly used just the Neo and laser in this round. And as a final comment, based on input the the iGolf technical staff many years ago my primary experience with the CAddie was with 'WAAS ON' and 'STABILIZER OFF' (just take the first stable reading) as the most accurate mode of operation. Today all GPS readings were done with WAAS ON and STABILIZER ON (the Neo and the Caddie).



    The Neo device (with Stabilizer ON) gives 'rock solid readings' that don't change. The Caddie device was better than it was with STABILIZER OFF, but it would still (on occasion - enough to be irritating) move around by up to 10 yards for no obvious reason.



    I started with my warm-up in the practice area while looking at the 2 GPS devices on occasion. Differences in readings to the same targets (note that BOTH devices were using identical course definition files) of 4-7 yards was common - not exactly the norm, but far from unusual. This continued to be true throughout the round (where I would occasionally take out the Caddie device for comparison with the Neo - the Caddie device was stored in a holder on my bag that leaves the 'antenna area' open).



    That is about all I will have to say about the comparison between the Neo and Caddie devices.



    I really liked how the Neo 'sets up' for me. I put it in the belt clip so that it was 'upside down' so all that I had to do to read it was reach down and kind of 'tip it up a bit' to read Front/Middle/Rear (all I was interested in). EXTREMELY convenient.



    I was playing Pinehurst No. 6 which is a very nice course that I have played often. I generally found the Neo readings within a few yards (no more than 4) of either course marked yardages or (more importantly) laser distances for those cases where I felt that I could easily make a comparison (not easy, BTW).



    There were a couple of exceptions.



    1) A few times I felt like the GPS was a good 5 yards off of 'correct'. That might have been, but this isn't totally out of line with expected accuracy across a round.



    2) There were two cases where the Neo clearly gave me an answer of "X" and a short time later (at the same position) gave an answer of "10 yards different than X".



    IMHO #1 is explained by the fact that, on occasion, GPS is a '5 yard technology'. I can accept that.



    My explanation for #2 is more subtle. STABILIZER ON (according to the documentation) "freezes the display reading once movement has ceased". If the device is capable of detecting that 'movement has ceased' why would the device find the need to change the display value regardless of the STABILIZER setting?????? I am guessing that the whole distance calculation thing is far more obscure and indirect than one might suspect. That said ....



    I was wearing the Neo on my belt on the left side (I just didn't like how it felt on the right side when I took a swing). AND I was riding on the right side of the cart (passenger). In that position the Neo is inside the cart which is a serious impediment to satellite reception.



    So I believe that a couple of times I got out of the cart and the STABILIZER froze the display coming out of quite poor satellite reception (inhibited by the roof of the cart). And that is why the reading that I got was around 10 yards different (and more correct) than the original reading. So I think that some care is due here (or maybe run with STABILIZER OFF - I find the CADDIE close to unusable with STABILIZER OFF, don't know about the NEO).



    Other comments.



    1) I liked the VERY FIRM tactile feedback from the key buttons. The 4 way toggle switch on the CADDIE was a bit easier use, but this was pretty good.



    2) Despite other comments I found the belt clip highly functional (unlike the Caddie device).



    3) A statement of satellite strength (as opposed to a few 'keystrokes' to get that info) would be helpful (like you got on the Caddie on the primary distance screens). But you are highly limited by this very small (a good thing) form factor, so I understand this trade off.



    4) The use of (apparently) standard USB cables is nice. I could go either way on the use of standard/rechargable AA cell batteries vs. the internal battery. The advertised 16 hour 'runtime' is nice on the Neo.



    5) I would really like to be able to combine laser and GPS to figure out if (for example) a front pin is 4 yards from the front edge or 9 yards. Given both inherent GPS accuracy and mapping accuracies (assuming relatively straight on approach angle), this may or may not be achieveable - can't tell yet.



    I have previously expressed concerns about the iGolf course mapping accuracy. I have so far found them pretty good on the Pinehurst courses, but quite iffy on other area courses (limited data at this point). I still have that concern.



    But over-all this was a pretty positive experience (particularly relative to the outstanding price point).



    dave
  • sharkharksharkhark Members Posts: 1,687 ✭✭
    I am ready to pull my hair out. I went to sync with my neo recently and it kept showinging in the upper left hand connected window that it was not connected. I was using the same usb cord and same port. Nothing different. I tried different ports, i tried a non original usb cord, i tried uninstalling the software and usb drivers, i tried downloading all over again all software and installing (even though i already had the most current firmware and sync software...sigh..!)

    but nothing.

    Emails to igolf (or L1) as they are called, is not helpful. I was told i could pay $20US and ship it from canada to California for them to 'look' at it and if it costs more then it will be at my cost as i have owned it a couple years. It works fine with files on it, it allowed me to map a new course and works fine, its just syncing.



    I have moved provinces (states for my US friends) and need to load all new 10 courses as i will be playing brand new courses to me..but cannot do so. I also am afraid of reinstalling firmware once again...as now i have mapped an entire course not in igolf library...and its only on the unit...so i dont want to lose it.



    any suggestions? I did start getting a microsoft active sync msg saying something alone lines the unknown device you are connecting is malfunctioning..blah..blah...but if i go into the advanced settings and look at the device and port its in...it says..just like it always did..that it is operating fine.



    help?
  • sharkharksharkhark Members Posts: 1,687 ✭✭
    sharkhark wrote:


    I am ready to pull my hair out. I went to sync with my neo recently and it kept showinging in the upper left hand connected window that it was not connected. I was using the same usb cord and same port. Nothing different. I tried different ports, i tried a non original usb cord, i tried uninstalling the software and usb drivers, i tried downloading all over again all software and installing (even though i already had the most current firmware and sync software...sigh..!)

    but nothing.

    Emails to igolf (or L1) as they are called, is not helpful. I was told i could pay $20US and ship it from canada to California for them to 'look' at it and if it costs more then it will be at my cost as i have owned it a couple years. It works fine with files on it, it allowed me to map a new course and works fine, its just syncing.



    I have moved provinces (states for my US friends) and need to load all new 10 courses as i will be playing brand new courses to me..but cannot do so. I also am afraid of reinstalling firmware once again...as now i have mapped an entire course not in igolf library...and its only on the unit...so i dont want to lose it.



    any suggestions? I did start getting a microsoft active sync msg saying something alone lines the unknown device you are connecting is malfunctioning..blah..blah...but if i go into the advanced settings and look at the device and port its in...it says..just like it always did..that it is operating fine.



    help?






    update!



    I just signed into igolf membership while plugged in and it now shows connected, but does not show the device, or courses on it or allow transfer.

    I am not sure why loggging into igolf even helped at least show it connected????

    I have used my sync software for years and you do not need to log in unless you are downloading new courses etc, i have never had to log in, i just fire up software, turn on my unit, wait until it shows main menu, then connect the usb and voila...it usually says connected and shows the current stable of courses on my unit along with allowing transfer or deletion.

    But right now it wont let me do anything?

    Help!!!!
  • sharkharksharkhark Members Posts: 1,687 ✭✭
    sharkhark wrote:

    sharkhark wrote:


    I am ready to pull my hair out. I went to sync with my neo recently and it kept showinging in the upper left hand connected window that it was not connected. I was using the same usb cord and same port. Nothing different. I tried different ports, i tried a non original usb cord, i tried uninstalling the software and usb drivers, i tried downloading all over again all software and installing (even though i already had the most current firmware and sync software...sigh..!)

    but nothing.

    Emails to igolf (or L1) as they are called, is not helpful. I was told i could pay $20US and ship it from canada to California for them to 'look' at it and if it costs more then it will be at my cost as i have owned it a couple years. It works fine with files on it, it allowed me to map a new course and works fine, its just syncing.



    I have moved provinces (states for my US friends) and need to load all new 10 courses as i will be playing brand new courses to me..but cannot do so. I also am afraid of reinstalling firmware once again...as now i have mapped an entire course not in igolf library...and its only on the unit...so i dont want to lose it.



    any suggestions? I did start getting a microsoft active sync msg saying something alone lines the unknown device you are connecting is malfunctioning..blah..blah...but if i go into the advanced settings and look at the device and port its in...it says..just like it always did..that it is operating fine.



    help?






    update!



    I just signed into igolf membership while plugged in and it now shows connected, but does not show the device, or courses on it or allow transfer.

    I am not sure why loggging into igolf even helped at least show it connected????

    I have used my sync software for years and you do not need to log in unless you are downloading new courses etc, i have never had to log in, i just fire up software, turn on my unit, wait until it shows main menu, then connect the usb and voila...it usually says connected and shows the current stable of courses on my unit along with allowing transfer or deletion.

    But right now it wont let me do anything?

    Help!!!!


    another update...now i went out of that window and when going back in...it did not show connected and no matter how i try now...it says it is searching and nothing is connected.

    i want to take a large hammer and smash this thing into bits...i want to then...take my neo...and put remnants thru a coffee grinder....i then want to take the fine powder dust that comes out and ...and...well you get my drift...



    how can an inanimate object...combined with a company that is simply an business..not even a real person....give me such a rage!!!!!!!!!!!!!!!!
  • stevestrikestevestrike Members Posts: 1,956
    Find another computer and try to sync with that. A laptop, or one at a friend's house. It is most likely something going on with your PC, and not the Neo itself unfortunately.
  • chas521chas521 Members Posts: 1,148 ✭✭
    edited May 31, 2011 #607
    My NEO is now about 3+ years old. The battery still holds a good charge and last about 3 rounds. What started happening this year is that while it stays connected to the satellites, it stays at a fixed yardage when I get to my ball until I start walking around and then it returns to normal. Let's say I'm 175 yards from the center of the green. When I first look at the NEO, it might show 184 yards. But when I walk around a bit and return to my ball now it shows the correct yardage. Hope I didn't confuse you. Never had this problem previously.

    Can anyone help? image/russian_roulette.gif' class='bbc_emoticon' alt=':russian_roulette:' />
    Post edited by Unknown User on
  • hort22hort22 Members Posts: 89 ✭✭
    so has anyone actually put a new battery into one of these things...think my battery is finally dying on me.



    contacted igolf/bushnell and they said go to igolf and search for batteries for your unit, so i did and found nothing...contacted them again and said cant find any...they say well there must not be any for your product...great service bushnell!



    when i asked about the model of the battery i never heard a response. *****s
Sign In or Register to comment.